StoreGrid Forum

Disable missed job queueing

Vembu StoreGrid: Online backup software for Service Providers, SMBs & ROBOs

Disable missed job queueing

Postby czoller » Mon Apr 02, 2012 2:06 pm

I did not see this question address here on the forums or in the documentation. We are using the Service Provider edition of StoreGrid v4.

As I understand it, by default, if a backup is currently running and it goes over into another backup job's scheduled time, that scheduled backup will be suspended and will then run after the currently-running job completes. Is there a way to disable this behavior? I want a missed job to run at its next scheduled time only, NOT after the current job. Otherwise, it makes it difficult to troubleshoot and repair failing or missed jobs since the missed job does not explain which other job interfered with it.
czoller
 
Posts: 53
Joined: Thu Mar 29, 2012 9:50 am

Re: Disable missed job queueing

Postby vidhya » Tue Apr 03, 2012 8:25 am

HI czoller

Unfortunately, the missed backup will always run after the previous completes. There is no way to disable it. You can however make the StoreGrid client run both the jobs at the same time. You can do this by changing the ThreadCount attribute of the <Module StartModule="602" ThreadCount="1 tag in the SGConfiguration.conf file in the conf/ folder in the client installation location.

From v4.2, we have added an attribute for this in the build-o-matic form itself in the partner zone. When you submit the request for branded v4.2 build, make sure you specify this ThreadCount value which will be then set in the branded client builds by default.

We're are planning to show this as ThreadCount option in StoreGrid Client web console itself in future.

Regards
Vidhya
vidhya
 
Posts: 1459
Joined: Fri Feb 29, 2008 8:14 am


Return to StoreGrid Discussions